Requisitos para o Software com Suporte

    Requisitos para o Joomla! 3. x

     

    Software Recomendado Mínimo Mais informação
    PHP[1]
    (com Magic Quotes GPC desativado, MB String Overload desativado)
    (Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default)
    5.6 ou 7.0 + 5.3.10 https://secure.php.net
    Bases de Dados Suportadas:
    MySQL[2]
    (suporte InnoDB necessário)
    5.5.3 + 5.1 https://www.mysql.com
    SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
    PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
    Servidores Web Suportados:
    Apache[3]
    (com mod_mysql, mod_xml e mod_zlib)
    2.4 + 2.4 + https://www.apache.org
    Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
    Microsoft IIS[6] 7 7 https://www.iis.net

     

     

    Requisitos para o Software com Suporte

    Requisitos para o Joomla! 1.6, 1.7, & 2.5

    o suporte terminou em 31 de dezembro de 2014

     

    Software Recomendado Mínimo Mais informação
    PHP 5.6  5.2.4 https://secure.php.net
    Bases de Dados Suportadas:
    MySQL 5.0.4 + 5.0.4 https://www.mysql.com
    SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
    PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
    Servidores Web Suportados:
    Apache[3]
    (com mod_mysql, mod_xml e mod_zlib)
    2.2 + 2.0 https://www.apache.org
    Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
    Microsoft IIS[6] 7 7 https://www.iis.net

     

     

    Requisitos para o Software com Suporte

    Requisitos para o Joomla! 1.5

    o suporte terminou em 31 de dezembro de 2012

     

    Software Recomendado Mínimo Mais informação
    PPHP[4] 5.3  4.3.10 https://secure.php.net
    Bases de Dados Suportadas:
    MySQL 4.1.x + 3.23 https://www.mysql.com
    SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
    PostgreSQL ( Nao Funciona ) Nao Funciona Nao Funciona https://www.postgresql.org/
    Servidores Web Suportados:
    Apache[3]
    (com mod_mysql, mod_xml e mod_zlib)
    2.0 + 1.3 https://www.apache.org
    Nginx ( Nao Funciona ) Nao Funciona Nao Funciona https://www.nginx.com/resources/wiki/
    Microsoft IIS[6] 7 6 https://www.iis.net

     

     

    Requisitos para o Software com Suporte

    Requisitos para o Joomla! 1,0

    o suporte terminou em 22 de julho de 2009

     

    Software Recomendado Mínimo Mais informação
    PPHP[4] 5.3  4.2 https://secure.php.net
    Bases de Dados Suportadas:
    MySQL 4.1.x + 3.23 https://www.mysql.com
    SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
    PostgreSQL ( Nao Funciona ) Nao Funciona Nao Funciona https://www.postgresql.org/
    Servidores Web Suportados:
    Apache[3]
    (com mod_mysql, mod_xml e mod_zlib)
    2.x + 1.3 https://www.apache.org
    Nginx ( Nao Funciona ) Nao Funciona Nao Funciona https://www.nginx.com/resources/wiki/
    Microsoft IIS[6] 7 6 https://www.iis.net

     

     

    Notas de Rodapé

    1] O PHP 5.3.1 pode ser utilizado das versões 3.0 até 3.2. No 3.3, a versão mínima foi aumentada para o PHP 5.3.10. As versões 3.5 e posteriores do Joomla! são compatíveis com o PHP 7.

    [2] O suporte para o conjunto de caracteres do MySQL `utf8mb4` foi adicionado no Joomla! 3.5 e será utilizado por defeito pelos servidores que o suportem

    [3] De forma a suportar os URL SEO, é necessário ter a extensão mod_rewrite do Apache instalada.

    [4] Não utilize PHP 4.3.9, 4.4.2 ou 5.0.4. Estas versões têm conhecido bugs que irão interferir com a instalação. O Zend Optimizer 2.5.10 para o PHP 4.4 também tem erros graves, deve pedir ao seu fornecedor de alojamento para atualizar para uma versão mais recente. As versões 1.5.15 e superiores do Joomla! são compatíveis com o PHP 5.3. Nota: A biblioteca OpenID não é compatível com a o PHP 5.3.

    [5] O suporte para Microsoft SQL Server foi adicionado na versão 2.5; 1.6 e 1.7 não têm esse suporte.

    [6] Para o Microsoft IIS (dependendo da sua configuração), poderá necessitar do seguinte:

    Para assistência adicional acerca da utilização do Microsoft IIS, consulte o Joomla! IIS Fórum .

    Opções de Configuração

    Se pretende instalar num computador local, existe uma série de pacotes de aplicações que o podem ajudar a ser mais rápido que utilizando aplicações individuais.

    • LAMP (Linux) - A maioria das distribuições de Linux vem com um servidor LAMP pré-configurado.
    • WAMP (Windows) - Para mais informações, visite o sítio Web do WampServer
    • MAMP (Apple OS) - Para mais informações, visite o sítio Web do MAMP
    • XAMPP (Multi-plataforma) - Não utilizar em sítios Web em produção. Para mais informações, visite o sítio Web do XAMPP

    Se necessitar de outras opções, recomendamos visitar os nossos fóruns de instalação para mais informações ou verifique a nossa lista de requisitos técnicos opcionais.

    Copyright © 2017 Joomla! Moçambique. Todos os Direitos Reservados. Joomla! é um software livre sob licença GNU/GPL.