ANÚNCIOS

    Joomla Moçambique notícias

    4 razões pelas quais você deve obter o PHP 7

    Com a perspectiva do Joomla 4, no próximo ano, gostaríamos de aumentar a conscientização sobre a necessidade de atualizar para o PHP 7.
    O Joomla 4 exigirá que o PHP 7 seja executado, conforme indicado neste anúncio. A maioria dos hosts já oferece o PHP 7 em seus pacotes e deve ser bastante fácil alterar sua versão do PHP. (Sugestão: antes de você, certifique-se de fazer backup) Se não, entre em contato com o seu host hoje.

    Deixe-nos dar-lhe 4 razões pelas quais você não deveria esperar ao atualizar o PHP.

     

    PHP 7 é melhor

    Fácil de dizer, é claro, mas o PHP 7 realmente possui uma melhoria de desempenho que faz seu site funcionar duas vezes mais rápido (em comparação com o PHP 5) e tem um consumo de memória de 50% melhor. Claro que o PHP 7 também é mais seguro e permite que você faça mais como desenvolvedor.
    Joomla 4 será incrível

    O Joomla 4 terá grandes melhorias para utilizadores e desenvolvedores. Um código limpo, um quadro renovado, excelentes recursos novos e muito mais. O Bootstrap 4 será implementado no núcleo, haverá 2 novos modelos (frontend e backend), o novo gerenciador de mídia será amado por muitos.
    Como o Joomla 4 ainda está em desenvolvimento e previsto para o segundo semestre de 2018, a lista de recursos impressionantes ainda se estenderá e será anunciada antes do lançamento.

    Estrutura Renovada

    O Framework renovado (versão 2.0) que vem com Joomla 4 tem algumas melhorias importantes. A API da base de dados suportará nativamente declarações preparadas, que é um grande aprimoramento de segurança. O armazenamento de dados criptografados agora será possível com um componente mais modular da Chave. As ferramentas de linha de comando podem ser melhoradas e mais seguras graças ao novo componente do console.
    Para obter uma lista completa de recursos, visite o roteiro.

    É mais seguro e suportado

    Versões anteriores a PHP 5.6 não são mais suportadas para correções de segurança. Se alguma grande vulnerabilidade for encontrada no PHP 5.3, ninguém vai consertá-la e seu site será vulnerável. Ao usar a versão mais recente, você sempre saberá que esses possíveis problemas serão atendidos, e as atualizações estarão disponíveis para você muito rapidamente quando houver um.
    Como o PHP 7 é a última versão principal, ele será suportado por um longo período de tempo (incluindo os lançamentos menores) para que o seu site Joomla 4 seja facilmente executado até 2025.

    Mas, mas ... E se eu não puder atualizar?

    Uma coisa importante a lembrar é que o Joomla 3.9 será suportado por dois anos após o lançamento. Isso significa que você pode executar o seu site Joomla 3 confortavelmente até 2020, mas você perderá todas as ótimas funcionalidades e benefícios do Joomla 4. Mas sejamos honestos, se seu host não estiver suportando o PHP 7 até agora, pode ser bom para procurar outra empresa de hospedagem.Exemplo nossa empresa www.aplichost.com

    Estamos firmemente empenhados em tornar a próxima geração do Joomla a melhor geração e sentir que abraçar o PHP 7 em frente ajudará a fornecer o produto de melhor qualidade para nossos usuários.
    M. Babker

     

    Copyright © 2018 Joomla! Moçambique. Todos os Direitos Reservados. Joomla! é um software livre sob licença GNU/GPL.